Shaolin

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Problem Description
Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.
 
Input
There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.
 
Output
A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.
 
Sample Input
3
2 1
3 3
4 2
0
 
Sample Output
2 1
3 2
4 2
 
Source
题意:找到最接近x的id;
思路:set二分可以写,练习treap;
#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
#define eps 1e-14
const int N=1e5+,M=1e6+,inf=;
const ll INF=1e18+,mod=;
struct Treap {
struct node {
node *son[];
int key,siz,wei,cnt,ID;
node(int _key,int _ID,node *f) {
son[]=son[]=f;
ID=_ID,key=_key;siz=cnt=;wei=rand();
}
void pushup() {
siz=son[]->siz+son[]->siz+cnt;
}
}*null,*root;
Treap() {
null=new node(,,);
null->siz=null->siz=;
null->wei=inf;root=null;// INF视情况而定
}
void rot(node* &rt,bool d) {
node* c=rt->son[!d];rt->son[!d]=c->son[d];
c->son[d]=rt;rt->pushup();c->pushup();rt=c;
}
void insert(const int &key,const int &ID,node* &rt) {
if (rt==null) {
rt=new node(key,ID,null);return ;
}
/*if (key==rt->key) {
rt->cnt++;rt->siz++;return ;
}*/
bool d=key>rt->key;
insert(key,ID,rt->son[d]);
if (rt->wei>rt->son[d]->wei) rot(rt,!d);
rt->pushup();
}
void remove(const int &key,node* &rt) {
if (rt==null) return ;
bool d=key>rt->key;
if (key==rt->key) {
if (rt->cnt>) {
rt->cnt--;rt->siz--;return ;
}
d=rt->son[]->wei>rt->son[]->wei;
if (rt->son[d]==null) {
delete rt;rt=null;return ;
}
rot(rt,!d);remove(key,rt->son[!d]);
} else remove(key,rt->son[d]);
rt->pushup();
}
node* select(int k,node* rt) {
int s=rt->son[]->siz+rt->cnt;
if (k>=rt->son[]->siz+&&k<=s) return rt;
if (s>k) return select(k,rt->son[]);
else return select(k-s,rt->son[]);
}
int rank(const int &key,node* rt) {
if (rt==null) return ;
int s=rt->son[]->siz+rt->cnt;
if (key==rt->key) return rt->son[]->siz+;
if (key<rt->key) return rank(key,rt->son[]);
else return s+rank(key,rt->son[]);
}
pair<int,int> pre(const int &k) {
node* t=root;int ret=;int ans=;
while (t!=null)
if (t->key<k) ret=t->key,ans=t->ID,t=t->son[];
else t=t->son[];
return make_pair(ret,ans);
}
pair<int,int> sub(const int &k) {
node* t=root;int ret=;int ans=;
while (t!=null)
if (t->key>k) ans=t->ID,ret=t->key,t=t->son[];
else t=t->son[];
return make_pair(ret,ans);
}
};
#define par pair<int,int>
int main()
{
int n;
while(~scanf("%d",&n))
{
if(n==)break;
Treap tree;
tree.insert(,,tree.root);
tree.insert(-(1e9),-,tree.root);
while(n--)
{
int id,x;
scanf("%d%d",&id,&x);
printf("%d ",id);
par p=tree.pre(x);
par q=tree.sub(x);
if(abs(p.first-x)<=abs(q.first-x))
printf("%d\n",p.second);
else
printf("%d\n",q.second);
tree.insert(x,id,tree.root);
}
}
return ;
}

最新文章

  1. vs2012 发布web应用程序
  2. entityframework学习笔记--002-database first
  3. js计时器
  4. RabbitMQ的工作队列和路由
  5. Android --Fragment中异步HTTP请求
  6. mac vim shell配置
  7. 对springMVC的简单理解
  8. HDU 4722 Good Numbers
  9. jvm的client和server
  10. mongodb备份还原
  11. poj2689 Prime Distance
  12. Weblogic12c 单节点安装
  13. 关于$\mathcal{D}(0,1)$上的一个有趣结论
  14. 斐讯自动下单抢购V1.3.4【自动验证码识别】
  15. 实战Python实现BT种子转化为磁力链接
  16. git add -A、git add -u、git add .区别
  17. Daily target小队介绍(刘畅,陈杰,杨有存,唐祎琳,王晓哲,邵汝佳)
  18. 【CodeForces】961 G. Partitions 斯特林数
  19. 如何在 cmd 中打开设备管理器,如何找到打开其他设备的命令?
  20. Android中破解应用签名校验的后续问题处理方案(闪退和重启现象以及无效问题)

热门文章

  1. python staticmethod and classmethod方法
  2. Java多线程开发系列之四:玩转多线程(线程的控制2)
  3. C# Linq 交集、并集、差集、去重
  4. Mount DVD on CentOS
  5. ecplise常用快捷键
  6. Spring学习笔记之三----基于Annotation的Spring IOC配置
  7. HTML5学习小结
  8. ios 使用AFN上传图片到服务器
  9. arm 2440 linux 应用程序 nes 红白机模拟器 第2篇 InfoNES
  10. C#利用反射机制创建对象