Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.

The following commands need to be supported:

BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.

FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.

VISIT <url>: Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.

QUIT: Quit the browser.

Assume that the browser initially loads the web page at the URL http://www.acm.org/

Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

Sample Input

VISIT http://acm.ashland.edu/
VISIT http://acm.baylor.edu/acmicpc/
BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/
BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT

Sample Output

http://acm.ashland.edu/
http://acm.baylor.edu/acmicpc/
http://acm.ashland.edu/
http://www.acm.org/
Ignored
http://acm.ashland.edu/
http://www.ibm.com/
http://acm.ashland.edu/
http://www.acm.org/
http://acm.ashland.edu/
http://www.ibm.com/
Ignored 其中模拟上网访问(visit)网页的前进(FORWARD)和后退(BACK)。可以用两个栈,一个保存前进的网页URL,一个保存后退的URL。
#include<iostream>
#include<cstring>
#include<stack>
using namespace std;
int main()
{
stack<string>Forward,Back;
string order;
string visit="http://www.acm.org/";
while(cin>>order&&order!="QUIT")
{
if(order=="VISIT")
{
Back.push(visit);
while(!Forward.empty())
{
Forward.pop();
}
cin>>visit;
}
else if(order=="BACK")
{
if(Back.empty())
{
cout<<"Ignored"<<endl;
continue;
}
else
{
Forward.push(visit);
visit=Back.top();
Back.pop();
}
}
else if(order=="FORWARD")
{
if(Forward.empty())
{
cout<<"Ignored"<<endl;
continue;
}
else
{
Back.push(visit);
visit=Forward.top();
Forward.pop();
}
}
else
{
cout<<"Invalid input"<<endl;
}
cout<<visit<<endl; }
return ;
}

最新文章

  1. TID大会学习心得之敏捷软件架构-微服务
  2. [转]JavaScript快速检测浏览器对CSS3特性的支持
  3. POJ2186 Popular Cows(强连通分量)
  4. ios UIWebView截获html并修改便签内容(转载)
  5. *[hackerrank]Volleyball Match
  6. Login failed for user &#39;NT AUTHORITY\NETWORK SERVICE&#39;的解决方法
  7. BZOJ 1260: [CQOI2007]涂色paint( 区间dp )
  8. hash在URL上的用法及作用
  9. 设计模式学习--组合模式,c++代码
  10. CarbonData-1:common
  11. [爬虫]采用Go语言爬取天猫商品页面
  12. abp 取消权限校验
  13. 【学习博客】Python学习初体验
  14. Svn启动窗口报错 Could not load file or assembly &#39;SharpSvn.dll&#39; or one of its
  15. 创世纪 BZOJ3037 &amp; [Poi2004]SZP BZOJ2068
  16. Batch Normalization 与 Caffe中的 相关layer
  17. 绑定任意格式的XML文档到WPF的TreeView
  18. svn一次性add/delete所有文件
  19. docker最新版本如何自定义配置文件
  20. 复习及总结--.Net线程篇(1)

热门文章

  1. laravel DB事物
  2. JAVA算法
  3. [daily][toolchain] 我的日常软件集
  4. 带你玩转JavaWeb开发之三 -JS插件实战开发
  5. 【Android测试】Android截图的深水区
  6. Highcharts 总结
  7. Java中Set Map List 的区别
  8. JMeter学习-023-JMeter 命令行(非GUI)模式详解(一)-执行、输出结果及日志、简单分布执行脚本
  9. linux下设置固定IP
  10. JVM 内部运行线程介绍