Power of Cryptography

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=99&page=show_problem&problem=49

http://poj.org/problem?id=2109

 
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 19772   Accepted: 9984

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest.  This problem involves the efficient computation of integer roots of numbers.  Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234

题意:给出n和p,求出 ,但是p可以很大(

如何存储p?不用大数可不可以?

先看看double行不行:指数范围在-307~308之间(以10为基数),有效数字为15位。

误差分析:

令f(p)=p^(1/n),Δ=f(p+Δp)-f(p)

则由泰勒公式得

(Δp的上界是因为double的精度最多是15位,n有下界是因为 )

由上式知,当Δp最大,n最小的时候误差最大。

根据题目中的范围,带入误差公式得Δ<9.0e-7,说明double完全够用(这从一方面说明有效数字15位还是比较足的(相对于float))

这样就满足题目要求,所以可以用double过这一题。

 #include<stdio.h>
#include<math.h>
using namespace std;
double n;
double p ; int main ()
{
// freopen ("a.txt" , "r" , stdin);
while (~ scanf ("%lf%lf" , &n , &p)) {
printf ("%.0f\n" , pow (p , 1.0 / n)) ;
}
return ;
}

转载:http://blog.csdn.net/synapse7/article/details/11672691

最新文章

  1. Android 自定义 attr
  2. [原]那些年整理的Linux常用命令,简单明了
  3. Win10系统出问题?简单一招即可修复win10!
  4. JBoss 系列十四:JBoss7/WildFly如何加载外部的文件或properties文件
  5. UI中一些不常用的控件UIActivityIndicatorView、UIProgressView、UISegmentedControl、UIStepper、UISwitch、UITextView、UIAlertController
  6. informix 查看 当前锁表
  7. PHP之验证码类
  8. shell 内网主机存活探测器
  9. Nginx 301重定向域名
  10. JVM里面hashtable和hashmap实现原理
  11. JS 匿名函数
  12. ISP(Interface Segregation Principle),接口隔离原则
  13. VIVO 手机重力传感器踩坑记录
  14. Oracle中 (+)与left join 的用法区别
  15. Python之从numpy.array保存图片
  16. 软件设计模式之工厂模式(JAVA)
  17. javaagent
  18. python之路----面向对象中的内置函数
  19. MyBatis-Plus 3.0.7.1
  20. YBT 5.2 树形动态规划

热门文章

  1. [30分钟]MSSQL快速入门教程
  2. [vijos1892]树上的最大匹配(树形DP)
  3. Boostrap(4)
  4. Jquery-获取父级元素parent
  5. CAS做单点登陆(SSO)——集成BIEE 11g
  6. 【SDOI2009】解题汇总
  7. BZOJ-1699 Balanced Lineup 线段树区间最大差值
  8. 超级懒汉编写的基于.NET的微信SDK
  9. BZOJ 3224 TYVJ 1728 普通平衡树 [Treap树模板]
  10. jquery ajax 应用返回类型是html json