Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem,
but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word
the shortest prefix that uniquely identifies the word it represents.



In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".




An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list
that begins with "car".

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity)
identifies this word.

(就是对于一个单词,输出到其不具有公共部分的一位,如果整个单词被其他词包含,就完全输出)

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Trie树真是神奇呢

/**/
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int chnum=26;
struct NODE{
int ct;//该节点被使用的次数
short a[26];//子节点
}n[15000];
int cnt;//总节点数
char c[2000][25];
void ins(char s[]){
int num=0,len=strlen(s);
int i,j;
for(i=0;i<len;i++)
{
if(n[num].a[s[i]-'a']==0){
cnt++;//增加节点
n[num].a[s[i]-'a']=cnt;
num=cnt;
}
else num=n[num].a[s[i]-'a'];//用已有结点 n[num].ct++;//该节点使用次数+1
}
return;
}
void Print(char s[]){
int num=0,len=strlen(s);
printf("%s ",s);
for(int i=0;i<len;i++){
num=n[num].a[s[i]-'a'];
printf("%c",s[i]);
if(n[num].ct==1) {
//printf("\n");//由于有些词是被完全包含在其他词里的,故不能在这里换行
break;}
}
printf("\n");
return;
}
int main(){
int i=0,j;
while(cin>>c[i] && c[i]!='\0')ins(c[i++]);
for(j=0;j<i;j++)Print(c[j]);
return 0;
}

最新文章

  1. 使用配置 API配置注入(Container stand-alone API)
  2. Java Reflection
  3. 从Nodejs脚本到vue首页看开源始末的DemoHouse
  4. BLAST - 序列数据库搜索
  5. win8安装mean.io详解
  6. 【linux】rpm常见命令
  7. http 302
  8. Yii 显示错误信息(Fatal Error,Warning)在页面上
  9. Pycharm使用技巧
  10. 【S】【S】【S】一大波前端干货整合(一)
  11. Visual Studio发布项目到远程服务器的步骤
  12. JS函数的属性
  13. 如何查看dede版本信息
  14. ucos-ii的任务调度机制
  15. 『片段』ShellHelper 控制台程序 的 程序调用(支持输入命令得到返回字符串输出)
  16. Maven之阿里云镜像仓库配置
  17. 表单提交前,判断webuploader是否上传
  18. aji unorder_map
  19. Setup Post-mission Camera
  20. [sh]getopt参数解析

热门文章

  1. C#.NET 大型通用信息化系统集成快速开发平台 4.0 版本 - 省市区数据权限的实现效果
  2. 通用权限管理系统数据字典 V3.9 版本,欢迎开发个各种业务系统的朋友们,参考表结构
  3. Number of Digit One
  4. Linux文件结构及基本文件夹
  5. CUDA2.1-原理之索引与warp
  6. WPF EventSetter Handler Command
  7. xml入门
  8. C#发展历程以及C#6.0新特性
  9. C#开发Windows服务
  10. 【NDK开发】android-ndk r10环境搭建